LEAP Canada

Third Party Outage affecting LEAP

Incident Report for LEAP Canada

Resolved

Third Party issue is resolved. We will continue to monitor.
Posted Oct 20, 2025 - 07:47 EDT

Identified

LEAP users may experience issues signing into or using LEAP as normal. We have identified an issue affecting a Third Party provider which impacts us directly. We are monitoring and will provide an update as soon as possible.
Posted Oct 20, 2025 - 04:22 EDT
This incident affected: LEAP Matter & Document Services, LEAP Accounting Services, LEAP Mobile, LEAP 365, and LEAP API Gateway.